ZABBIX优化、如配置文件优化、后台数据库优化……
4 篇帖子 分页: 1 / 1
帖子ryf3064 » 2016年 1月 26日 16:40 星期二
首先我是编译安装的 ./configure --prefix=/usr/local/zabbix --enable-server --enable-proxy --enable-agent --with-mysql=/usr/bin/mysql_config --with-net-snmp --with-libcurl --enable-java 但是按照网上的方法修改了zabbix_server.conf和setting.sh之后 启动zabbix_java/start.sh是后出现如下的错误
[root@zabbix zabbix_java]# ./startup.sh
Exception in thread "main" java.lang.ClassFormatError: com.zabbix.gateway.JavaGateway (unrecognized class file version)
at java.lang.VMClassLoader.defineClass(libgcj.so.10)
at java.lang.ClassLoader.defineClass(libgcj.so.10)
at java.security.SecureClassLoader.defineClass(libgcj.so.10)
at java.net.URLClassLoader.findClass(libgcj.so.10)
at java.lang.ClassLoader.loadClass(libgcj.so.10)
at java.lang.ClassLoader.loadClass(libgcj.so.10)
at gnu.java.lang.MainThread.run(libgcj.so.10)
Zabbix Java Gateway did not start
帖子oulin_hl » 2016年 1月 26日 17:17 星期二
1,请检查JAVA_HOME变量是否设置;

2,请检查/etc/hosts中是否配置本机计算机名的解析;
代码: 全选
ZABBIX中文论坛
欢迎热爱zabbix的网友们,在此我们可以一起探讨、交流、沟通zabbix的所有操作与问题!
帖子ryf3064 » 2016年 1月 28日 10:09 星期四
您好请教您,这个zabbix自带的zabbix_java gateway功能应该如何配置安装呢! 还有就是他对jdk的版本有要求么! 我便已安装的zabbix的版本是2.4.5我安装的jdk的版本是1.8.0_40  这个有兼容性问题么! 我的jdk装完了 /etc/profile文件也设置了,java -version的版本也改为1.8.0了但是还是回报这个错误无法启动zabbix_java
帖子bdz001002 » 2018年 11月 21日 00:08 星期三
这个应该是jdk版本兼容性问题
4 篇帖子 分页: 1 / 1

登录

在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客