ZABBIX服务安装,如在RedHat、CentOS、Ubuntu等上安装
1 篇帖子 分页: 1 / 1
帖子remotemountain » 2017年 12月 22日 15:57 星期五
zabbix-server启动失败,zabbix-web提示zabbix-server未启动,从以下原因分析

1. 系统的selinnux状态必须改为disabled或者permissive

系统认为zabbix-server违反了selinux的安全策略,禁止zabbix-server的启动

两种方式:临时+永久

selinux的状态设置为permissive

- cli:sduo setenforce 0临时设置为 permissive模式,不用重启
- 需要重启机器

sudo vi /etc/selinux/config
修改selinux mode 为 permissive

SELINUX=permissive


2. 防火墙需要关闭,或者将zabbi-server、zabbix-agent、zabbix-proxy加入防火墙信任端口

如果是自己平时测试,建议直接关闭

3. 若agent和server安装在同一台机器上,agent的配置文件需做如下改变

$ sudo vi /etc/zabbix/zabbix_agentd.conf
### Option: Server
# List of comma delimited IP addresses (or hostnames) of Zabbix servers.
# Incoming connections will be accepted only from the hosts listed here.
# If IPv6 support is enabled then '127.0.0.1', '::127.0.0.1', '::ffff:127.0.0.1' are treated equally.
#
# Mandatory: no
# Default:
# Server=

Server=10.4.30.111 #Server改成虚拟机或者物理机的ip,不要用localhost或者127.0.0.1

4. 查看zabbix-server的日志文件
$ sudo vi /var/log/zabbix/zabbix_server.log
#以下是日志内容,报错,连不上数据库(mariadb10,和zabbix按在同一台虚拟机上的)
[Z3001] connection to database 'zabbix' failed: [2002] Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
出现以上错误,修改server的配置文件
$ sudo vi /etc/zabbix/zabbix_server.conf
#修改DBHost,原来是127.0.0.1,改完再重启应该就可以了
DBHost=10.4.30.111
以上是我近期安装zabbix踩的坑,如果你也遇到相似问题的话,希望对你有用
1 篇帖子 分页: 1 / 1

登录

在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客